WikiList Installation

This installation guide was written for WikiList 0.5. © 2014 Geoffrey De Belie

Requirements and dependencies

You need: You might want to install: You will need either pgrep, pidof or ps + awk. You probably have one of them.

Installation

Your installation procedure depends on the operating system you are using.

Linux

Gambas can be automatically installed by this script if you are using Arch Linux, Debian (>=7), Ubuntu (>= 12.04) or Linux Mint (>=13). If you do not meet these requirements, install Gambas first and execute this script after that.

To install WikiList, execute these commands as root: If you don't have bash, use sh installwikilist.sh. Bash is only needed for Debian and it's decendants.

Ubuntu/Linux Mint

You can install Gambas 3.5.1+ and WikiList by executing these commands: You don't need to use the first step if you are using Ubuntu 14.10 or higher.

Debian

Debian 7 does not have recent Gambas packages. To install WikiList, execute these commands as root: On Debian 8, you can simplify these to:

Fedora

Download the RPM file and double click it. Give your password when asked: WikiList is now installed!

Slackware

Mageia 4

To install WikiList on Mageia 4, follow these steps: This was tested on Mageia 4, KDE version but should work also on the GNOME edition.

Mageia 3 and below / Mandriva

Packages are provided for Mageia and Mandriva. However, you will need to compile Gambas yourself since the the shipping version in Mageia/Mandriva is too old (WikiList needs Gambas 3.5.1+). See http://gambasdoc.org/help/install/mageia or http://gambasdoc.org/help/install/mandriva for instructions on how to compile Gambas. You additionally will need gcc-g++ and svn, which can be installed with urpmi.

SUSE

To install WikiList on OpenSUSE, first install gambas3-runtime: You can also use the root command line to install gambas3-runtime. Replace openSUSE_Factory with the version of OpenSUSE, for example openSUSE_13.1 (if you don't, it will still work).
  1. zypper addrepo http://download.opensuse.org/repositories/Education/openSUSE_Factory/Education.repo
  2. zypper refresh
  3. Answer t or a on the question: Do you want to reject the key, trust temporarily, or trust always? [r/t/a/? shows all options] (r): t
  4. zypper install --no-confirm gambas3-runtime
You can do that in a GUI way too:
Start YaST2, select Software Repositories and check "openSUSE-Education Updates" repository. Click on activate and start YaST Software Management to install gambas3.

After you've installed gambas3-runtime, download and install the WikiList RPM file for OpenSUSE, which can be found at the top of the page.

Windows

Currently, the Windows version is in development.
www.000webhost.com